[HARDHAT] Network used while executing tests

Hi Everyone,

I’m facing an issue with Hardhat tests (using Chai/Waffle)

I needed to deploy multiples contracts during my tests, including PancakeRouter.

The problem is that it seems that this contract’s size is too important to be deployed (Error “Transaction ran out of gas”).

=> Deployment works well when I’m commenting functions.

I know that there is a flag “allowUnlimitedContractSize” which can be set in the hardhat.config “networks” object.

But which network is used when we test ?

What is the best practice ?

I ran an hardhat node thinking it will execute tests on this but it doesn’t.

Can someone help me please ?

Thanks ! :pray:

Problem solved !

I had to add a default network in my module.export :
defaultNetwork: "hardhat",

then in my “networks” object :
hardhat: {
chainId: 1337,
allowUnlimitedContractSize: true

1 Like