Should the Solidity docs give some guidance on naming conventions?

Some modern languages like Rust give specific recommendations on naming conventions.

It is sort of an unofficial community standard in Solidity to use camelCase for function names. Should we officialize this by mentioning in the Solidity docs?

Do you mean something like this here in the Style Guide?

Whops, I missed that. I searched for camelCase in the docs, not for mixedCase.

Very well then!

1 Like